Tagsistant

All your files, quickly and easily.


Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Building errors

Building errors 1 year 1 month ago #80

  • ксовиран
  • ксовиран's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 1
  • Karma: 1
hello forum.
having troubles with building tagsistant on Ubuntu 13.04:
checking for EXTRACTOR_loadDefaultLibraries in -lextractor... no
libextractor is a universal metadata extractor...configure: error: "libextractor not found"
while i have installed all extractors and libextractors existing in the repo
Warning: Spoiler! [ Click to expand ]

any advice?
The administrator has disabled public write access.
The following user(s) said Thank You: admin

Building errors 1 year 1 month ago #81

  • admin
  • admin's Avatar
  • OFFLINE
  • Administrator
  • Posts: 3
  • Karma: 0
ксовиран wrote:
hello forum.
having troubles with building tagsistant on Ubuntu 13.04:
checking for EXTRACTOR_loadDefaultLibraries in -lextractor... no
libextractor is a universal metadata extractor...configure: error: "libextractor not found"
any advice?

I still have to check, but I suppose Ubuntu 13.04 ships a libextractor version newer than the one shipped with Ubuntu 12.04 I'm using. Unfortunately the two must be incompatible. As soon as I have time I'll setup a 13.04 virtual machine and try to build Tagsistant on it, doing the necessary porting.

Stay tuned.

p.s. You probably already know this, but just to make sure: Tagsistant 0.6 doesn't use libextractor, so you should be able to compile it.
The administrator has disabled public write access.

Building errors 1 year 1 month ago #82

  • ticso
  • ticso's Avatar
  • OFFLINE
  • Administrator
  • Posts: 64
  • Thank you received: 10
  • Karma: 3
Could you please post the output of:
dpkg -l | grep libextractor
The administrator has disabled public write access.

Building errors 1 year 1 month ago #83

  • ксовиран
  • ксовиран's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 1
  • Karma: 1
hello again.
p.s. You probably already know this, but just to make sure: Tagsistant 0.6 doesn't use libextractor, so you should be able to compile it.
what you mean? does it use libextractor and i should compile it or it doesn't use it? :)
i tried to compile 0.6 with error above, tried to compile 0.2, with error "configure: error: cannot run /bin/bash ./config.sub" so i'm stuck right now.
Could you please post the output of:
i've deleted all libextractors but apt-cache defines versions of libextractor3, libextractor-dev, libextractor-dbg as 1:0.6.3-5ubuntu2.
The administrator has disabled public write access.

Building errors 1 year 1 month ago #84

  • ticso
  • ticso's Avatar
  • OFFLINE
  • Administrator
  • Posts: 64
  • Thank you received: 10
  • Karma: 3
ксовиран wrote:
hello again.
p.s. You probably already know this, but just to make sure: Tagsistant 0.6 doesn't use libextractor, so you should be able to compile it.
what you mean? does it use libextractor and i should compile it or it doesn't use it? :)

Tagsistant 0.6 does not use any version of libextractor. So if you try to compile Tagsistant 0.6, having libextractor installed or not does not matter.

Tagsistant 0.7, on the other hand, uses libextractor version 0.5 (so far), while Ubuntu 13.04 provides libextractor 0.6, which has a different interface. That's the reason why you are having problems: you are compiling Tagsistant 0.7 on Ubuntu 13.04.

I'll do the porting of Tagsistant 0.7 to libextractor 0.6 and later versions as soon as possible. Meanwhile, you can download libextractor 0.5 from:

ftp.gnu.org/gnu/libextractor/libextractor-0.5.23.tar.gz
The administrator has disabled public write access.
The following user(s) said Thank You: ксовиран

Building errors 1 year 1 month ago #85

  • ксовиран
  • ксовиран's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 1
  • Karma: 1
thanks! i was building 0.7 version indeed but since download page doesnt says that directly, thought it was 0.6.
everything build and seems working. i've had to register manually libextractor path by this guide.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.171 seconds
Powered by Kunena Forum